
Talking Calendar

The Talking Calendar provides an easy-to-use way of managing your appointments.    The Talking Clock 
can be used to alert you when it's time for an appointment.

Managing Appointments
Creating New Appointments
Viewing Appointments
Editing Appointments
Removing Appointments
Printing Appointments

Using Appointment Books
Creating New Appointment Books
Opening Appointment Books
Saving Appointment Books
Combining Appointment Books
Holidays

Using Talking Calendar Windows
Managing Windows
Calendar Windows
Dayview Windows
Appointment Windows
Icon Bar

Changing Preferences



Managing Appointments

Talking Calendar lets you create, view, edit, and save your appointments.    Appointments can be saved in 
Appointment Books, and the Talking Clock can announce alarms for these appointments.

Talking Calendar appointments can have several attributes.    The time and duration specify when and 
how long the appointment is.    You can choose a message to remind you what the appointment is about.   
The frequency of appointments can be specified; for instance, you may have daily or weekly 
appointments.    Each appointment can also have a type, which determines how the appointment's icon 
will appear.    Each appointment may also have a media element attached to it, which will play when the 
Talking Clock signals an alarm for the appointment.
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Creating New Appointments

To create a new appointment, you first need to create a new Appointment window.    Choosing New 
Appointment from the Window menu is one way to create an Appointment window.    You can also press 
the New button in a Dayview window, or edit a blank appointment slot.

You then should specify all settings that apply to your appointment.    When done, press OK to create the 
appointment, or Cancel to abandon it.

See also Appointment Windows, Dayview Windows, and Appointment Settings.



Viewing Appointments

Talking Calendar provides three different types of windows for viewing appointments.

Calendar windows allow you to see an entire month at a glance.    An icon will show the first non-daily 
appointment--or holiday--of each day.

Dayview windows show all appointments for a given day.

Appointment windows show only one appointment.    They are mainly used to view and change specific 
details about a single appointment, such as its duration, time, or frequency.

See also Appointment Windows, Dayview Windows, and Calendar Windows.



Editing Appointments

To edit appointments, you must first create an Appointment window with the desired appointment in it.    

Using a Dayview window, you can either double-click on the desired appointment or select it and press 
Edit.    You can then make any changes you want to.    

When done, you should press OK to keep your changes, or Cancel to abandon them.

See also Appointment Windows, Dayview Windows, and Appointment Settings.



Removing Appointments

Although you may want to keep old appointments for your records, you may also want to remove them 
from your appointment book.

You can delete appointments that are no longer needed by using a Dayview window.    

In a Dayview window, simply select the appointments you want to delete and press the Del key or the 
Delete button.    Or, you can drag the Eraser icon to the title bar of the Dayview window.

If the appointment is currently in an Appointment window, you can drag the Eraser icon to the window's 
icon or title bar to remove the appointment.

Note: 
If you accidentally remove appointments you wanted to keep, you should choose the Undo option as soon
as possible.    Only one deletion action (possible involving several appointments) can be undone.

See also Appointment Windows, Dayview Windows, and Appointment Settings.



Printing Appointments

You can print appointments for any day or range of days in the currently loaded appointment book.

Select Print... from the File menu to bring up the Print dialog.    

You can configure the printer, such as choosing paper size and resolution, using the Setup... button.    

The From and To options in the Print range section allow you to specify the range of dates for which 
appointments will be printed.    

The Fonts... button allows you to specify which font will be used to print the schedule.    If you do not 
choose a font, a default font will be used.

Once printing starts, you can cancel the print operation using the Cancel button.



Using Appointment Books

An appointment book is a file which contains appointments.      If different users use the same machine, 
they may each want a separate appointment book.    With Talking Calendar you can maintain separate 
appointment books, and copy appointments between them.    You can also import any alarms you may 
have created in the Talking Clock as appointments.
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Creating Appointment Books

You can create a new appointment book by choosing New from the File menu.    If you've made changes 
to the currently loaded appointment book, you'll be prompted to save it first.    A new appointment book 
has no appointments defined.



Opening Appointment Books

To open an existing appointment book, choose Open... from the File menu.    As above, if you've made 
changes to the currently loaded appointment book, you'll be prompted to save it first.

Note that with Open... you can read alarms from previous versions of the Talking Clock shipped with 
Wired for Sound and Wired for Sound Pro 1.x.    Simply choose "Talking Clock 1.x, 2.x" as the file type 
and open the TCLOCK.INI file.    You cannot save appointments in a format the old Talking Clock can 
recognize using Talking Calendar, however.    The Talking Clock which comes with this version of Wired 
for Sound can read Talking Calendar appointments, however.



Saving Appointment Books

To save the currently loaded appointment book, choose Save from the File menu.    If you haven't given it 
a name yet, you'll be prompted to give it a name and to specify where to save it.

If the Talking Clock is running when you save your appointment book in Talking Calendar, it will update its 
alarm list if the appointment book you saved was the one it was using for alarms.      It is not necessary to 
re-open the appointment book in Talking Calendar.
 
If you'd like to save an appointment book under a new name, choose Save As...    You'll be prompted to 
supply a name and specify the directory to save the appointment book under.    If you choose the name of 
an existing appointment book, it will be overwritten with the appointments you're saving.    For this reason,
you'll be asked for confirmation if you choose an existing name.    This option will not remove or alter the 
appointment book with the currently loaded appointment book's previous name.

The Save As... option allows you to choose Appointment Book or Holiday file as the file type.    See 
Holidays for details on Holiday files.

The Save As.... option also allows you to make the appointment book the default appointment book.    The
default appointment book is automatically loaded when Talking Calendar is loaded.    This default applies 
to Talking Clock as well.



Combining Appointment Books

Use the Merge option to read the appointments from another appointment book into the currently loaded 
appointment book.    The appointment book you're reading the appointments from will not be changed.

To save the appointments in the current appointment book into another saved appointment book, choose 
Save Into...    This option is similar to Save As..., except that it does not remove all appointments from an 
existing appointment book with the same name.

Note that like the Open command, the Merge... command can read alarms from earlier versions of Talking
Clock



Holidays

Although Talking Calendar comes with a standard set of holidays that are automatically loaded when 
Talking Calendar loads, you can edit the holidays.

Holiday files are intended for appointments that rarely change but are important.    In addition to the usual 
holidays, you may want to add birthdays or anniversaries to the holiday file.

The holidays are by default stored in TCAL.HOL, but you can change this.    You can open the holiday file 
like any standard appointment book.    Just choose Holiday file as the file type.    You'll be in holiday mode,
and instead of having the standard appointment types, you'll have types for various holidays.    Holidays 
are created just like standard appointments.    When you're finished, use the Save As option to save the 
holidays.    You can save the file under a different name--and if you check the Make Default button, this file
will become the default holiday file for Talking Calendar and Talking Clock.

The same holiday file is used by Talking Clock and Talking Calendar.



Using Talking Calendar Windows

Within the main Talking Calendar window can be many sub-windows.    These will be of three types:

Calendar windows
Dayview windows
Appointment windows

In addition, there is the Icon bar, which provides several easy-to-use shortcuts for appointment 
modification, creation, and removal.    The Icon bar always appears below the Talking Calendar menu, 
above other Talking Calendar windows.

Icon Bar



Managing Windows

The Talking Calendar's multiple-window interface is similar to that of the Program or File Manager:

o You can maximize or minimize the individual Talking Calendar windows.
o You can activate a window by choosing it from the Window menu.
o You can cascade windows or arrange icons using options under the Window menu.

There are a few differences:

o The Talking Calendar windows are fixed in size.    You can move them around by clicking and 
dragging either their title bars or the frame.

o You create new windows by using the New... options under the Window menu.
o You cannot tile Talking Calendar windows. 



Calendar Windows

Calendar windows provide an overview of an entire month's appointments.    You can display any month 
of any year (1900-2000) in a Calendar window.

Calendar windows indicate with icons the appointments for a given day.    In general, the icon will 
represent the first appointment of the day; however, daily appointments are not shown. 

Every Calendar window has an associated Dayview window which always reflects the currently 
highlighted day in the calendar.    

You can create additional unattached Dayview windows by double-clicking on the desired day.
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Creating Calendar Windows

You may have as many Calendar windows open at the same time as your system can handle. 

You can create additional Calendar windows by using the New Calendar option under the Window menu.  
A    calendar of the current month, with the current day selected, will be shown.



Changing the Date of Calendar Windows

You can change the selected day of the month in any Calendar window by clicking on the date with the 
mouse or by using the arrow keys to move the selection rectangle around.

You can change the month by using the buttons labeled with the previous and next month, or by choosing
a month from the list of months below the calendar.    The PgUp and PgDn keys will choose the previous 
and next month, and Home and End will go to the beginning and end of the currently selected year.

You can change the year by selecting it from the list of years below the calendar.    

Note that changing the date in a Calendar window will change the appointments shown in the associated 
Dayview window and its associated Appointment windows.

You can also change the date shown in a Calendar window by changing the date in its associated 
Dayview window.



Closing Talking Calendar Windows

You can close a Calendar window if it is active by choosing Close from the Window menu.    Or, you can 
select Close from its system menu (located in the upper-left corner of the window).    Or, you can double-
click on the system menu.



Dayview Windows

 Dayview windowsprovide a representation of the times and durations of all appointments on a given day. 
It also displays "empty" time slots, which can be used to create new appointments.
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Creating Dayview Windows

You can have as many Dayview windows as your system can handle open at once. 

You can create a new Dayview window by double-clicking on the appropriate day in any Calendar 
window, or by choosing the New Dayview option from the Window menu.    The latter option creates a 
Dayview window showing appointments for the current day.

Note that when you create a Calendar window , an associated Dayview window is automatically created.



Changing the Date of Dayview Windows

You can change the day, month, and year shown in a Dayview window by selecting the desired day, 
month, or year from the appropriate list boxes.    The previous and next buttons allow you quickly to view 
the appointments on the previous or next day.

You can select an appointment from the list shown by clicking on it.

Note that if there is a Calendar window associated with a Dayview window, changing its date will change 
the date of the calendar as well.    

You can change the date of a Dayview window which is associated with a Calendar window by changing 
the date in the Calendar window.



Appointment Windows

Appointment windows allow you to modify all attributes of an appointment, including its message, time, 
duration, frequency, type, and associated sound.
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Creating Appointment Windows

You can have as many Appointment windows as your system can handle.

You can create a new Appointment window by double-clicking on an appointment or "empty" time slot in a
Dayview window, clicking on the New button in a Dayview window, or by choosing New Appointment 
under the Window menu.

You can create an Appointment window of a given appointment type by dragging the appropriate 
appointment type icon onto either a specific date in a Calendar window or any Dayview window.

You can change the type of an appointment window by dragging the appropriate icon onto its icon or title 
bar.



Appointment Settings

Appointment windows allow you to set several options for the given appointment.

Setting Function
Message The message will be displayed when the appointment is listed.    Also, when the 

alarm is announced, this message will be displayed.    If the speech synthesis 
module is installed, the message will be read with the synthesized voice when 
the appointment is announced.    The message can be anything you want which 
described the appointment, such as "Meet with Joe."

Frequency Determines how often the alarm will be announced.    You can choose once-only, 
daily, weekly, weekdays, weekends, monthly, or yearly.

Type Determines the type of appointment.    This setting determines how the 
appointment is announced, and which icon represents it in Talking Calendar.

Date Determines what day or days the appointment is on.    Depending on the 
frequency, not all day options be selectable.    For instance, for a monthly 
appointment only the day of the month can be selected.    The other date settings 
are ignored.

Time Determines the time of day the appointment is.    If the appointment doesn't have 
a specific time (such as a birthday or holiday), you may use any time.    You can 
adjust the time by sliding the slider or clicking on the arrows on either side of it.

Duration Determines how long an appointment is.    Use the slider to change this.    The 
display is in hours:minutes format. 

Action Determines what Talking Clock does when it announces the alarm.    "Announce 
only" will announce the appointment's type and time.    "Play media element" 
allows you to specify a media element to be played.    "Run program" allows you 
to run any Windows application when the appointment's time arrives.    Press the 
Media Element... or Program... button to change the media element or 
application, respectively.

When you've selected all the appointment attributes, press OK to keep them or Cancel to abandon any 
changes you've made.

Note:
Appointments are not inserted into the schedule until you press OK.    Appointments in Appointment 
windows will not be saved unless you first press OK to insert the appointment into the schedule.



Icon Bar

The Icon bar contains icons which represent the different types of appointments you can have in Talking 
Calendar.    Two additional icons, an Eraser and a Trumpet, can be used to remove appointments and 
hear the appointments in a given window, respectively.

To use the icons, simply click on the one you want, move the mouse over the desired window, and 
release the pointer.    The mouse pointer will show a universal "no" sign if you cannot drop the icon on the 
window.

Depending on how large the Talking Calendar window is, not all appointment icons may be visible.    Use 
the left and right buttons in the Icon bar to scroll the icons left and right.

Icon Type Function
Appointment Icons You can change the type of an appointment in an Appointment window by 

dragging one of the appointment type icons to an Appointment window.    Note 
that if the Appointment window is not minimized, you should drop the icon on its 
title bar.    

You can create a new appointment of a given type by either dropping the desired 
type icon on a Dayview window or on the desired day in a Calendar window.

Eraser Icon You can remove the appointment which appears in an Appointment window by 
dropping the Eraser on the appointment.

You can remove all selected appointments in a Dayview window by dropping the 
Eraser on the Dayview window.

Note: 
If you accidentally remove appointments in this way, you can use the Undo 
function to undelete them.

Trumpet Icon You can hear a description of a specific appointment by dropping the Trumpet 
icon on an Appointment window.

You can hear a run-down of all the appointments in a given day by either 
dropping the Trumpet icon on a Dayview window or on a specific day in a 
Calendar window. 

Appointments will be read with the current voice and face selected for Talking 
Calendar.    These can be changed using the Voice setup... and Face setup... 
options under the Edit menu.



Appointment Book

A file which contains appointments.    You can have multiple appointment books on one machine--for 
instance, one for each user, or one for different types of appointments.



Calendar Window

A Talking Calendar window which shows appointments in a calendar format.



Dayview Window

A Talking Calendar window which shows all appointments for a given day.



Appointment Window

A Talking Calendar window which shows all details of a specific appointment.



Changing Preferences

The Preferences dialog box allows you to customize the way the date appears in various parts of Talking 
Calendar.

You can choose how you want the date displayed in the captions of the different Talking Calendar 
windows by entering a format string.    To specify these formats, you create time and date "pictures," 
similar to formatting strings in Microsoft Excel.    An example of a formatted time will appear.

The following are characters that can appear in time and date pictures:

Characters Effect
h Hour (12-hour format)
hh Hour with preceding zero
H Hour (24-hour format)
HH Hour (24) with preceding zero
m Minutes, if after an hour, w/o zero.    Otherwise, the month in numerical form 

(4/11/92)
mm Month (04,11/92)
mmm Month (Jan,, Feb.)
mmmm Month (January, February)
d Day (03, 14)
dd Day (3, 14)
ddd Weekday (Mon., Tue.)
dddd Weekday (Monday, Tuesday)
yy Year (92)
yyyy Year (1992)
a a or p
aa am or pm

Note that a, m's, and d's can be capitalized to cause the resulting string to be capitalized.

Other characters in the format string, such as : or -, can be used between these special date and time 
strings.    If you'd like to have a special character appear, precede it with a backslash (\).    To include a 
backslash, include two backslashes (\\).

Examples

All these examples show how various time and date format strings show August 9, 1992 at 3:09pm:

Format String Resulting Display
h:mm aa 3:09 pm

HHmm 1509

m/d/yy 8/9/92

mm/dd/y 08/09/92

mmm d, yyyy Aug. 9, 1992

dd    MMMM yy 09 AUGUST 92

mmmm d, yyyy h:mm a
August 9, 1992 3:09 p



\D\a\y: d/m/y Day: 8/9/92

\Hour: h:mm Hour: 3:09

mmmm d, yyyy_h:mm a
August 9, 1992 3:09 p



Media Element

A media element is any multimedia file, such as a sound file (waveform or MIDI), a video clip (such as 
AVI), or a Windows bitmap.    If you have the speech synthesis module, text files are also treated as media
elements--they will be read by the synthesis engine whern played.    Talking Clock in general allows any 
type of media element to be specified when you can choose a media element for a chime or appointment.




